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1. HPLS®-2G EVALUATION SOFTWARE 

1.1. Overview 
The software bundled with the HPLS®-2G configures, collects, and analyzes 

data from the unit. 

This software also features: 

• real-time text monitoring 

• A graph view of collected data 

• A list of logged data for further analysis 

The HPLS®-2G – Evaluation Software monitors data from the Heading 

Position Leveling System in real-time, via an RS 232 protocol serial 

communications port. 

This chapter provides information on how to: 

• set up a communications (comms) link. 

• display, edit, and export data to other software applications. 

• manage collected output, including: 

o compass and attitude information (roll, pitch, and yaw). 

o GPS information (latitude, longitude, altitude, UTC, and 

quality and number of satellites in view). 

o chip temperature. 

1.2. Communication 
The PC software communicates with the HPLS®-2G unit through a standard 

PC RS-232 (or Rs-422) serial port that must be configured prior to 

monitoring activity. 

You can use a USB to RS-232 (or Rs-422) converter in the absence of an 

RS232 serial port. 

1.2.1. Serial Port Configuration 
To configure the serial port: 

1. Connect the supplied harness cable from the PC to the HPLS®-2G unit. 

2. Launch the Evaluation software. 

3. From the main screen, select HPLS®-2G Communication Port. 

 

Figure 1. HPLS®-2G Communication Port 
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4. In the Communication Port Dialog box, select the communication 

port (the first COM port detected is the default) but do not change the 

baud rate (default of 115200). 

 

Figure 2. Port Setup 

5. Click OK to confirm selection. 

The Open Comm Port indicator turns on (Figure 3). 

 

Figure 3. Open Comm Port 

 

6. Click Open Comm Port on the Toolbar to initialize real-time data flow. 

7. Turn On the HPLS®-2G unit. 

Tip If no data is displayed, verify that the HPLS®-2G unit is on. 

 

The initialization notification screen is displayed. 

 

Figure 4. HPLS®-2G Initialization 
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After the Comm port is opened, the HPLS®-2G displays real-time 

information in the data view pane of the main screen. 

As soon as at least four (4) GPS satellites are in view, the HPLS®-2G also 

displays latitude, longitude, altitude, and other information in the data view 

pane of the main screen. 

8. To stop the display of real-time information, click Close Comm Port. 

 

Figure 5. Close Comm Port 

1.3. Data Views 
You can view incoming data packets textually or graphically. 

1.3.1. Textual View 
The textual view displays incoming data packets in real-time in the data view 

pane of the main screen. 

The data view pane displays the real-time data shown in Figure 6 and 

described in Table 1. 

 

Figure 6. Data View Pane 
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Table 1. Real-Time Data View Pane 

Ref Section 
Name 

Description 

1 

 

General The fields in this section are: 

• Index - packet index value (numbered 
consecutively)  
The background is red if the value does not 
follow consecutively from the previous value 
(indicating a missing packet). 

• Version - version of the embedded software 

• Date - current date (UTC) 

2 Tilt & Heading 
[Deg] 

The fields in this section are: 

Roll, Pitch, and Yaw 
The HPLS®-2G determines these values, which are 
expressed in degrees. 

3 Position 
Information 

The fields in this section are: 

• UTC - time (in seconds) since 
01 January 1970. 

• LAT - latitude in degrees and minutes 

• LON - longitude in degrees and minutes 

• ALT - altitude in meters 

• Qual - quality of GPS reception (0 = locked 
position, 2 = x/y axis, 3 = x/y/z axes) 

• No. Sat - number of satellites viewed by the 
GPS 

• CSEP - calculated distance between antennas 
(up to three decimal places). 

• MSEP - measured distance between antennas 
(affects the heading and the only valid value is 
0.1) 
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Ref Section 
Name 

Description 

4 Flags [Hz] The fields in this section are: 

• GGA 

• HDT 

• CSEP 

• Roll 

• Pitch 

• Temp 

• MSEP 

The value of the above fields depends upon the period 
configuration (for example, 1, 2, 5, or 10). 
The field background turns red when the value is -1 or 
+1, relative to the selected frame rate. 
 

• PPS 

The value of the above field should be 1. 

The field background turns red when the value does 
not equal 1. 
 

To see NMEA messages, go to View>GPS Port-
NMEA>NMEA log (enforced using the second 
communication port). 

5 Online GPS 
Status 

This section contains the GPS bits status information. 

P.GPS, S. GPS, D.GPS, and DIFF: 

• The circle to the left of the bit name is green 
when the GPS lock is established. 

• The circle to the left of the bit name is black 
when the GPS has lost lock. 

Heading (information supplied by Arazim) 

• The circle to the left of the Heading is green 
when the GPS established lock on heading 
calculation. 

• The circle to the left of the Heading is black 
when the GPS lost heading calculation lock. 

6 Heading Filter For HPLS®-2G – Multi-Freq Only, these bits indicate 
the Yaw filter status. 

See Filtered Heading [Deg]  

When the HPLS®-2G detects static mode: 

• The circle to the left of Static Mode turns from 
black to green once static mode is detected. 

• The circle to the left of Valid Value turns from 
black to green once static mode is detected 
and algorithm has determined that the filtered 
heading value is valid. 
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Ref Section 
Name 

Description 

7 Online BIT 
Status 

The fields in this section are used to indicate a 
deviation from a predefined working range (Temp, 
Inclination, Voltage). 

• The circle to the left of an item turns green 
when the current value is within the permitted 
range. 

• The circle to the left of an item turns red when 
the current value exceeds the permitted 
threshold. 

Power V1 = 3.3 V 

Power V2 = 5.0 V 

Power V3 = 12.0 V 

Missing messages (checked every 2 seconds): 

• The circle to the left of Missing Messages turns 
green when there are no missing messages. 

• The circle to the left of Missing Messages turns 
red when there are missing messages. 

8 Filtered 
Heading [Deg] 

When the GPS is in static mode, Arazim filters the Yaw 
value to minimize the amount of noise. 

9 Temp. [Deg/C] The field in this section displays the current 
temperature in degrees Celsius. 

10 Statistic [Mean, 
Std]-[Deg] 

The fields in this section contain the mean and 
standard deviation for Roll, Pitch, and Yaw. 

• Click ∑ once to display the mean and standard 
deviation for each field. 

• Click ∑ again to clear the display. 

 

11 Turn-on BIT/ 
System Info 

BIT (Built-in Test) upon initialization to verify that there 
is communication and to test communication quality. 

System Info: GPS receiver with which HPLS®-2G 
works + identification of main board 

 

1.3.2. Graphical View 
The graphical view displays incoming data packets in the Graphical 

Viewer panel of the main screen. 

To select the Graphical View, go to View>Full Form View on the main 

screen. 
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Figure 7. Selecting Full From View from Menu 

 

The Graphical Viewer panel displays the options shown in Figure 8 and 

described in Table 2 

 

Figure 8. Graphical Viewer 

 

Table 2. Graphical Viewer Icons 

Ref Icon Name Description 

1 Play View incoming data. 

2 Stop Stop viewing incoming data. 

3 Erase Clear the chart view 

4 View 
temperature 

Toggle enable/disable the temperature display. 

5 View Roll Toggle enable/disable the roll display. 

6 View Pitch Toggle enable/disable the pitch display. 

7 View Yaw Toggle enable/disable the yaw display. 
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1.3.3. Full Form View 
Full Form view displays the same information as the numeric view, with the 

addition of information in chart form at the bottom of the screen. 

Go to View>Full Form View to view this information. 

 

Figure 9. Full Form View 

 

1.3.4. Numeric View 
Numeric view displays the same information as the full form view but does 

not include information in chart form.  

Go to View>Numeric View to view this information. 

  

Figure 10. Numeric View 
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1.3.5. HDT Raw Data View 
HDT raw data view includes information on the accelerometer data for the X, 

Y, and Z axes (measured in gs -- where 1g indicates that the device measures 

gravity) and rate-gyro raw data (measured in degrees per second). 

Go to View>HDT Raw Data View to view this information. 

 

 

Figure 11. HDT Raw Data View 

 

1.3.6. Flags Visual Warning 
Use the Flags Visual Warning view to set message notification thresholds for 

one or more measurements.  

To set the flags visual warning: 

1. Go to View>Flags Visual Warning. 

Flags Proper Boundaries is displayed. 

2. Check the measurement(s) desired and fill in the minimum and 

maximum values. 

3. Click OK. 

When a measurement goes below or above the set thresholds, the 

background for each measurement will turn red. 
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Figure 12. Flags Proper Boundaries 

 

1.3.7. GPS Port - NMEA 
Set viewing criteria to view GPS Port NMEA message notifications.  

To view specific GPS Port NMEA message notifications: 

1. Verify that you are connected to Port B. 

2. Go to View>GPS Port-NMEA. 

3. Select NMEA log or NMEA SAT Info. 

NMEA Messages is displayed. 

4. Under MASK, check one or more messages to view (or click Set All).  

5. Under Constellation, check one or more systems to view (or click Set 

All). 

6. Click Close. 

Note Be sure to configure the GPS to transmit the selected 

messages. 
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Figure 13. GPS Port - NMEA 

 

1.3.8. GPS Port - Bin Messages 
Set viewing criteria to view GPS Port Bin messages.  

To view specific GPS Port Bin message notifications: 

1. Verify that you are connected to Port B. 

2. Go to View>GPS Port Bin Messages. 

3. Select GPS Port - GPS SNRs or GPS Port - GNSS SNRs. 

GPS Port Bin Messages is displayed. 

Figure 14 displays the position (per angle) above the observer of the primary 

and secondary antennas (the top graphic).  

It also displays the signal noise ratio (SNR) (the bottom chart).  

Note The SNR is the ratio between the desired information or the 

power of a signal and the undesired signal or the power of 

the background noise (expressed in decibels). 
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Figure 14. Double Antenna Position and SNR 

 

Figure 15 displays the reception information of the primary and secondary 

antennas (both in terms of Master (Primary) vs. Slave (Secondary) and in 

terms of the satellite-based augmentation system (SBAS). The SBAS 

improves the integrity, accuracy, and availability of basic Global Navigation 

Satellite System (GNSS) signals by transmitting wide-area corrections for 

range errors. 

To view specific criteria: 

1. Select one of the constellations in the top row of tabs, and 

2. Select a frequency (L1, L2, or L5). 
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Figure 15. Receiver Full Information 

 

Note TOW = Time of Week  - Number of seconds between Sunday 

at midnight and the current time 

Week = Number of weeks from 01 January 1980 to the 

current date 

PRN ID = pseudo-random noise identification 

A repeating radio signal broadcast by each GPS satellite and 

generated by each GPS receiver. In a given cycle, the 

satellite and the receiver start generating their codes at the 

same moment, and the receiver measures how much later 

the satellite's broadcast reaches it. 

 

1.4. HPLS®-2G Configuration 
The HPLS®-2G unit is configured from the HPLS®-2G Configuration screen. 

To open the HPLS®-2G Configuration screen: 

• Go to Setup> HPLS®-2G Config in the main screen. 
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Figure 16. HPLS®-2G Configuration Menu 

or 

• Click the HPLS®-2G Setup icon in the toolbar. 

HPLS®-2G Configuration is displayed. 

 

Figure 17. HPLS®-2G Configuration 

 

The HPLS®-2G Configuration Controls are described in the following 

subsections. 

1.4.1. Enter Configuration 
Select Enter Configuration for the HPLS®-2G to enter the Configuration 

mode. 

When Enter Configuration succeeds: 

• The Enter Configuration button displays: Exit Configuration. 

• The system receives an "Ack" message and sends a message to the  

HPLS®-2G to return the current settings. 

• All information fields are updated with the current settings. 
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To enter information: 

1. In each field of the HPLS®-2G Configuration screen, select (if there is a 

combo box) or enter information. 

2. Click Set to save the information to RAM. 

3. View the Log Information panel on the right side of the screen to see 

updated information for the fields for which you clicked Set in Step 2. 

1.4.2. Read Settings 
Select Read Settings for the HPLS®-2G to read the HPLS®-2G current 

settings and display the values of the information fields in the HPLS®-2G 

Configuration screen. 

1.4.3. Save Settings 
Select Save Settings for the HPLS®-2G to burn the current parameters to 

the flash memory. Do not click Save Settings if you want to retain the settings 

only for the current session. 

1.4.4. Reset Device 
Select Reset Device to reboot the HPLS®-2G system. 

1.4.5. Load from File 
Select Load from File to load a previously saved configuration. 

1.4.6. Save to File 
Select Save to File to save a configuration to a selected file. 

1.4.7. Exit Configuration 
Select Exit Configuration (after you enter the configuration, Enter 

Configuration changes to Exit Configuration) to exit the configuration 

and then click Close to close HPLS®-2G Configuration. 

1.4.8. Configuration Settings 
The HPLS®-2G configuration settings are listed in Table 3. 

Table 3. HPLS®-2G Configuration Settings 

Ref Name Description Configurable 

1 Interface Baud 
Rate 

Communication speed between 
HPLS®-2G and the PC 

Yes 

2 Work mode This option may be available in the 
future. 

No 

3 Message Type System output message type Yes 

4 Messages Rate Number of system output 
messages provided per second 

Yes 
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Ref Name Description Configurable 

5 Temperature 
Overrange 
Indication 
(degrees) 

Minimum and maximum 
temperature (typically from -20 C. 
to 70 C.) range. Over range will 
lead to alarm bit. 

Yes 

6 Inclination 
Overrange 
Indication 
(degrees) 

Minimum and maximum inclination 
(typically from -30 C. to 30 C.) 
range. Over range will lead to 
alarm bit. 

Yes 

7 Firmware version Firmware version and build 
(separated by a hyphen) 

No 

8 M. Separation 
(meters) 

Distance that the GPS was 
configured to measure 

Enter this accurate value directly 
into the GPS module via the GPS 
Configuration screen 

Yes 

9 Heading Shift 
(degrees) 

Change in heading required to 
match the actual heading 

Yes 

10 Log Information Real-time display of configuration 
settings when you click Set after 
each setting. 

No 

 

Important You can only enter the configuration screen when 

the COM-port is open. 

1.5. Save and Record Real-Time Data 
To save and record real-time data to a file: 

1. From the toolbar in the main screen, click Select Destination File 

Name. 

 

Figure 18. Save and Record Real-Time Data Button 

 

The Save As dialog box is displayed. 

2. Provide a file name and path in which to save the real-time data. 

After the system saves the file name and path, Record is enabled. 

3. Click Record to start recording. 

4. Click Stop to stop recording. 

5. When the recording is finished, click Stop. 
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Table 4. Data Recording Actions 

Button Action Comments 

Start Starts recording Recording only starts when there is a 
valid data flow. 

Pause and Stop buttons are enabled 

Pause Pauses recording Recording is paused temporarily. 

Stop and Record buttons are enabled. 

The recording file remains open. 

Press Record again to restart recording 
and add new data to the end of the file. 

Stop Stops recording Stop the recording process. 

Close the recording file. 

All buttons except Select Destination File 
Name are grayed out. 

1.6. Export Data 
Currently, you can only export data from M1 message source files. 

To export data: 

1. Go to File>Export. 

 

Figure 19. File Export Menu 
 

Export Form is displayed. 
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Figure 20. Export Form 
 

2. Select the M1 Message source file location. 

3. Select the destination location and file name. 

4. Click Export to export the file to the destination. 

5. Click Close. 

1.7. Configure the GNSS Receiver 
 

Important 

Select a COM 2 port that connects to Port-B of the 

HPLS®-2G but retain the other settings as they are for 

the COM 1 port. 

 

To configure the GNSS Receiver using icons: 

1. Connect the supplied harness cable from the PC to the HPLS®-2G unit. 

2. Launch the Evaluation software. 

3. From the main screen, select GPS Communication Port. 

 

Figure 21. GPS Communication Port 

 

4. In the Communication Port Dialog box, select the communication 

port (the first COM port detected is the default) but do not change the 

baud rate (default of 115200). 
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Figure 22. Port Setup 

 

5. Click OK to confirm selection. 

Figure 23 shows the Open Comm Port indicator. 

 

Figure 23. Open Comm Port 

 

Configure the GNSS Receiver using menus: 

1. From the main screen, select Ports>GPS Config. Port and open the 

newly selected COM2 port. 

 

Figure 24. GPS Config. Port 
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2. Go to Set-Up>GPS Config from the main screen or 

 

Figure 25. GPS Configuration Menu 

 

Click the GPS Configuration button. 

 

Figure 26. GPS Configuration Button 
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The GPS Configuration screen is displayed (Figure 27). 

 

Figure 27. GPS Configuration Control Commands 

 

Important 

Check with Arazim Support before changing any GPS 

parameters. 

 

The left panel contains the GPS Control commands: 

• Read Config – Reads the information in the main portion of GPS 

Configuration (original and current values). 

• Write Config – Writes configuration changes to HPLS®-2G RAM 

registers. 

• Save Config – Saves the current RAM registers values to flash memory. 

In addition, the left panel contains subscription and version information. 

 

The main panel contains the types of GPS Information available to view 

(Figure 28 to Figure 31, inclusive). 

To view information on specific GPS information: 

1. Click the tab of interest. 

2. Double-click an item of interest under a tab of interest to view that item’s 

current values at the bottom of the screen. 

3. If relevant, enter new values in the detailed fields. 
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4. Click Set to set the new values. 

5. Click Read Config. to read the information in the main portion of GPS 

Configuration, as well as the latest “Sub-scription” and Log details. 

6. Click Clear to clear the log information. 

7. Click Write Config to save the new configurations to RAM. 

8. Click Save Config to save the new configurations to flash memory. 

 

Figure 28. GPS Heading Information 

 

• Manual Value - Manually measure the distance between the center of 

two antennas and update the Current Value if necessary. 

• Calculated Value - This read-only value displays the calculated 

distance between the center of two antennas. 

• Flip Board - For factory use only. 

• Heading Bias - If the antennas are not set along the driving direction, 

insert the offset value between the antenna heading and the vessel 

platform heading. 

Contact Arazim Support for information on the following GPS Heading 

Information options: 

• GYRO AID 

• LEVEL AID 

• TILT AID 
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• Tilt Type 

• Smooth Heading 

• Smooth Leveling 

 

 

Figure 29. GPS Diff. GPS Information 

 

 



  Table of Revisions  

 

HPLS-2G®  Page 30 

 

 

Figure 30. GPS Config/NMEA Configuration 

 

The Config/NMEA TAB displays the message configuration for HPLS®-2G 

Port B.  

 



  Table of Revisions  

 

HPLS-2G®  Page 31 

 

 

Figure 31. GPS Misc Configuration 
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1.8. Administration 
The options available under the Administration tab assist in: 

• System calibration 

• Simulation  

• Firmware updates 

1.8.1. Burn Calibration 
To burn the calibration results to flash memory: 

1. Go to Admin>Burn Calibration. 

Burn Calibration opens. 

2. Under Calibration Result view the sensitivity for roll and pitch and the 

offset for roll and pitch. 

3. To update the HPLS®-2G calibration settings: 

a. Under Control, click Load Cal. to load the calibration arguments 

from a file.  

b. Under Calibration Result view the loaded calibration arguments   --   

sensitivity for roll and pitch and offset for roll and pitch. 

c. Click Burn Cal. to burn the calibration arguments to the HPLS®-2G 

flash memory. 

4. To read and backup the current calibration arguments: 

a. Under Control, click Read Cal. to read the burned calibration result 

from the HPLS®-2G. 

b. Under Calibration Result view the loaded calibration arguments -- 

sensitivity for roll and pitch and offset for roll and pitch. 

c. Click Save Cal. to save the result.  

Under Calibration, you can view the calibration log. 

5. Click Clear Log to clear the calibration log. 

6. Click Close to close the Burn Calibration dialog. 
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Figure 32. Burn Calibration 

 

1.8.2. File Player Simulator (M1) 
You can use the file player simulator to check that the software and the serial 

port are working properly. 

To start the file player simulator: 

1. Perform the following in parallel: 

a. Connect the cross-serial port cable. 

b. Activate two HPLS®-2G applications, one to receive data, and another 

to transmit data 

2. On the receiving application, select and open the communication port 

according to Section 1.2.1 (Figure 1 to Figure 3). 

3. On the transmitting application, go to Admin>File Player Simulator 

(M1). 

The HPLS®-2G Simulator opens. 
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Figure 33. HPLS®-2G Simulator 

 

4. Under Communication Port, click Select Port. 

The Communication Port Dialog opens. 

 

Figure 34. Communication Port Dialog 

 

5. Select a port and a baud value (115200, HPLS®-2G default). 

6. Click OK 

7. Under Communication Port, click Open Port. 

8. Under Selecting Source File, click Browse, then select the simulation 

file from the list of files displayed. 

The file information is displayed in the File Information section. 

9. Under Settings, select a frame rate. 
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10. [Optional] Click Loop Enabled to have the frame rate repeat in a loop. 

11. Use the following buttons to control the simulation play: 

a. Single - Play a single message at a time. 

b. Continuous - Play messages continuously until end of the file (if you 

left Loop enabled unchecked). 

c. Pause - Pause the message play. 

d. Reset - Reset the simulator -- reset the simulation file to the 

beginning. 

12. To finish the simulation: 

a. Click Pause. 

b. Under Communication Port, click Close Port to close the port. 

c. Click Close to close the simulator. 
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1.8.3. FW Update 
To update firmware: 

1. Be sure that the HPLS®-2G device interface harness is connected (from 

Port A) to the PC 

2. Go to Admin>FW Update. 

Firmware Upgrade opens. 

3. Under Firmware File, click the menu button (three dots to select a 

valid binary file. 

A file browser opens. 

4. Click Select Port to select a port (Figure 35). 

 

Figure 35. Firmware Upgrade - Select Port 

 

5. Click Open Port to open the port (Figure 36). 

 

Figure 36. Firmware Upgrade - Open Port 

 

6. Turn On the HPLS®-2G device. 

7. Verify that the Firmware Upgrade application and the device are 

connected. 

Burn Firmware is active. 

8. If the application and device are not connected, verify that you have 

selected the correct port and baud-rate, then recycle power to the  

HPLS®-2G device. 
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9. Press Burn Firmware to begin uploading the new firmware to the 

device. 

If the process succeeds, the bar graph will be full and a message indicating 

that the upgrade has ended will be displayed. 

10. Recycle power to the HPLS®-2G device before working with it. 

 

 


